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Kepware Knowledge Base: Solution


Service Timeouts Occur when Running KEPServerEX as a Service


Last Update: 11/7/2018

Problem:
When using the Allen-Bradley ControlLogix Ethernet Driver in Logical or Physical mode, the driver must upload the PLC project in order to make optimized calls to the device.

Possible Cause:
For large PLC projects, this upload may take several minutes. During this wait time, the service may time out. The default maximum setting for the service timeout is 5 seconds.

Solution:
Increase the timeout for all services. To do so, open the Windows Registry and navigate to HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control. Then, add a new DWord value called "ServicesPipeTimeout" and assign its value in milliseconds. For example, setting ServicesPipeTimeout to 240000 milliseconds gives the service 4 minutes to start. Once finished, reboot the machine so that the changes can take effect.