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The License Utility's View Licenses Dialog Does Not Display the Correct License Information After Processing a Response File


Last Update: 11/12/2018

Problem:
After importing a response file ("response.txt") for a KEPServerEX V5 activation request, the License Utility's "View Licenses" dialog does not display the license being activated.

Possible Cause:

  1. The license was activated on server version 5.0, and was then transferred off (banked back to Kepware). The user is attempting to activate the license on the same server from which it was transferred.
  2. The user activated a demo license on a PC, and is attempting to activate a permanent license of the same product on top of that time-limited license.
  3. A user experiencing a system failure uses the Emergency Activation ID to get the system running on a new server, but attempts to re-activate the permanent license are not successful.
  4. Though very rare, system conditions can occur where the License Utility loses its initialization of Trusted Storage.

Solution:

  1. In KEPServerEX version 5.0, the license entry in Trusted Storage was not immediately cleared when a license was transferred. This left the license in a disabled state instead of being deleted. When a user attempts to reactivate the license, the activation will not complete successfully because it is still listed as disabled. Server version 5.1 and later automatically clear licenses out of Trusted Storage when a transfer request file is generated. The user should upgrade to V5.1 or later and then repeat the activation process. Once the disabled license has been removed from Trusted Storage, the activation will complete successfully.
  2. Kepware's licensing system stamps a version date into each license on generation. Depending on when the licenses were generated, the demo license may have a greater version date than the permanent license. The License Utility examines the version date stamped into the license to determine which license should trump another license of the same product. The license that has the greatest version date wins. To successfully activate the permanent license, the user must transfer the demo license from the License Utility and then repeat the activation process. Users do not need to process the "transfer_request.txt" file for the demo license because they are one-time use licenses and cannot be banked back to Kepware.
  3. The License Utility stamps a version date into each license on generation. Emergency Activation IDs have their version date set at the time of activation to allow users to recover their system regardless of the version of KEPServerEX available. Depending on when the Emergency Activation ID was activated, it could have a greater version date than the permanent license. The License Utility examines the version date stamped into the license to determine which license should trump another license of the same product. The license that has the greatest version date wins. To successfully activate the permanent license on top of an Emergency Activation ID, users must transfer the Emergency Activation ID from the License Utility and then repeat the activation process. Users do not need to process the "transfer_request.txt" file for the Emergency Activation ID because they are one-time use licenses and cannot be banked back to Kepware.
  4. Normally, initialization of Trusted Storage occurs during server installation and is transparent to the user. When initialization fails to occur or is lost, the first attempt of a license will fail. Instead of activating the license, the License Utility uses the first activation attempt to initialize Trusted Storage. Once initialized, subsequent activation attempts will be successful on the first attempt. If this issue is encountered, users can repeat the activation process to correct the problem.


Notes:

  1. All KEPServerEX V5.0 licenses are eligible for V5.1.
  2. Kepware can adjust the number of times an Emergency Activation ID can be used, and will grant an additional use to a customer when an Emergency Activation ID is needed. This can be accomplished by contacting Kepware to discuss re-commissioning the application after system failure.
Related Products
KEPServerEX