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Automatic Tag Generation Fails when Importing the CSV Generated from Productivity Suite Software


Last Update: 11/12/2018
Problem:
The "Unable to generate a tag database for device <device name>. Reason: Import file is invalid or corrupt" error message is sometimes received when trying to generate tags from the CSV file exported from Productivity Suite software.

Possible Cause:
After Productivity Suite software version 1.3, an additional field was added to the export file for each tag that is used in the import and export of the tag database into the Productivity Suite. The driver marks this field as invalid, and will fail to complete the tag import as a result.

Solutions:

1. Edit the CSV file and remove the field. For more information, refer to the instructions below.

  1. Open the CSV file in Excel or a similar application.
  2. Next, delete the last column (which would be the fifth column or O in Excel).
  3. Save the CSV file. Then, try automatic tag generation with the new file.

2. Update to the latest version of the Productivity Suite. Automation Direct addressed this issue in Productivity Suite V1.10. For more information, refer to the instructions below.

  1. Open the device project. In the main menu, select File | Export | Tags.
  2. Next, specify an output file name (such as "Test Project"). Once finished, click OK.

    Note:
    The Productivity Suite will now generate two CSV files: "Test Project_basic.csv" and "Test Project_extended.csv".
  3. Use "Test Project_basic.csv" for automatic tag generation.