Use the search and browse feature to view Kepware's repository of more than 500 Knowledge Base articles. Narrow your results or type your query into the search field below.

Search Solutions Results By: View All Solutions

Kepware Knowledge Base: Solution


Is KEPServerEX affected by the "Heartbleed" security bug?


Last Update: 11/7/2018
"Heartbleed" is a security vulnerability in OpenSSL, a popular open-source library used to protect usernames, passwords, and sensitive information sent over a network. For more information, refer to heartbleed.com.

Although KEPServerEX uses the OpenSSL library components to secure OPC UA connections, neither KEPServerEX version 4 or 5 are affected by the security vulnerability. KEPServerEX's OPC UA support does not include the HTTPS transport, and uses a version of the software library that is not vulnerable to the Heartbleed security bug.
Related Products
KEPServerEX