検索機能を使用して 500 を上回る Kepware の知識ベース記事の中から閲覧します。結果を絞り込むか、クエリーを下部の検索フィールドに入力します。

解決策が見つからなかった場合には、当社の PTC eSupport Portal で追加資料を確認することもできます。eSupport Portal へのログインを要求された場合、My Kepware の認証情報を使用できます。My Kepware アカウントが必要ですか? こちらで作成

各種検索方法:
View All Solutions

Kepware Knowledge Base: Solution


What Libraries Are Required When Using the Fanuc Focas Ethernet Driver?


Last Update: 2018/11/12

The Fanuc Focas Ethernet driver requires that the Fanuc Open CNC Focas 1 / Ethernet Library (part number A02B-0207-K732) or the Fanuc Focas 2 Library (part number A02B-0207-K737) be installed on the system. These libraries provide an Ethernet communications interface between the hardware and driver. They do not have a user interface and do not need to be configured in any way. The essential pieces of the libraries are FWLIB32.DLL (version 1.12.0.2 or later) and FWLIBE1.DLL (version 1.6.0.2 or later). Although earlier versions may be used, unsolicited communication will not be supported. These DLLs must be installed in the Windows system folder. The location of the appropriate system folder depends on the operating system version:

  • 32-bit Windows operating systems: C:\Windows\System32
  • 64-bit Windows operating systems: C:\Windows\SysWOW64
  • Legacy Windows NT/2000 operating systems: C:\WINNT\system32
Note: To use this driver's unsolicited messaging capability, install the unsolicited message server application "UMsgServ.exe" (version 1.0.0.1 or later). This is available from the distributor.
Related Products
Fanuc Focas Ethernet , GE Suite