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Kepware Knowledge Base: Solution


Unable to Connect Using DDE While UAC Is Enabled


Last Update: 2018/11/12

Problem:
Users are unable to make a DDE connection using KEPServerEX on Vista and higher operating systems.

Possible Cause:
User Access Control (UAC) was introduced in Windows Vista and has been included in all Windows versions. When the server is running interactively and the logged in user has elevated privileges, the client must be started with elevated privileges (such as a member of the administrators group).

Solution:
When UAC is enabled, start the client with elevated privileges. To do so, right-click on the DDE client and select Run as administrator.

Windows 7, 2008 R2, and 8.x operating systems allow executables to be configured to run with administrator privileges. To configure a program to run as an administrator, right-click on the executable and then select Properties. Next, navigate to the Compatibility tab and locate the Privilege Level section. Then, check Run this program as an administrator.

Note:
UAC can still be enabled if both the logged in user account and the DDE client are running as basic users.

Related Products
DDE Client