検索機能を使用して 500 を上回る Kepware の知識ベース記事の中から閲覧します。結果を絞り込むか、クエリーを下部の検索フィールドに入力します。

解決策が見つからなかった場合には、当社の PTC eSupport Portal で追加資料を確認することもできます。eSupport Portal へのログインを要求された場合、My Kepware の認証情報を使用できます。My Kepware アカウントが必要ですか? こちらで作成

各種検索方法:
View All Solutions

Kepware Knowledge Base: Solution


DDE Connections to the Server with User Access Control (UAC) Enabled


Last Update: 2018/11/07
Problem:
The connection fails when running on a Windows Vista or higher operating system and making a DDE connection to the server from a DDE client or when connecting from the DDE Client Driver to a DDE server.

Possible Cause:
UAC is all about access privileges. The server is most likely running elevated with Administrator privileges and the client is running as a User. The DDE client must have the same privileges or higher as the DDE server in order to establish the connection. The connection should succeed if the client is running as an Administrator and the server is running as a User.

Solution:
The client must be run as an Administrator in order to connect to the server. To do so, right-click on the shortcut to launch the client and then select Run as an administrator. If the client is launched at start-up, the shortcut properties can be edited to force the client to run as administrator.