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Kepware Knowledge Base: Solution


Error 1722 Encountered During KEPServerEX V5 Installation


Last Update: 2018/11/12

Problem:
The following error is displayed during the KEPServerEX V5 installation: "Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor." This generic message usually results in a rollback of the install.

Possible Cause:
1. The Microsoft Visual C++ redistributables that are packaged in the KEPServerEX installation have failed to install.
2. The OPC Core Components have failed to install or could not be upgraded by the KEPServerEX installation.
3. System policies have prevented the last action of the KEPServerEX installation from succeeding.
4. Windows Task Scheduler is disabled.

Solution:
1. Download and install the latest Microsoft Visual C++ 2008 redistributable package before attempting to install KEPServerEX. KEPServerEX version 5.10 and earlier will also require the Microsoft Visual C++ 2005 redistributables.
2. Registered OPC Foundation members can obtain a standalone installation for the OPC Core Components. Other users can contact Kepware's Technical Support team for the necessary files.
3. KEPServerEX version 5.13 and later may resolve issues with the final step of the installation that were caused by Certificate Revocation List checks on highly-secure computers.
4. Enable the Task Scheduler so that the installer can create a task to start the Administrator tool during user login.